Cara Mengatasi Error Composer Does Not Allow Connection to Packagist

Singkat saja gan, cara mengatasi error composer yang tidak mau terkoneksi ke packagist.org, atau lebih tepatnya karena settingan composer yang sudah menggunakan koneksi secure SSL, tapi packagist masih ndeprok pake HTTP biasa.

Contoh error seperti ini:


Cara memperbaikinya cukup sederhana. Buka file composer.json pada direktori tersebut, lalu tambahkan konfigurasi untuk menonaktifkan SSL composer:


"config" : {
"secure-http": false
},

Silakan dicoba kembali,

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: