20K Situs WordPress Diekspos oleh Plugin Tidak Aman REST-API

Lebih dari 20.000 situs WordPress rentan terhadap injeksi kode berbahaya, penipuan phishing, dan lebih banyak lagi sebagai akibat dari bug skrip lintas situs (XSS) dengan tingkat keparahan tinggi yang ditemukan di Perancang Template Email WordPress – WP HTML Mail, sebuah plugin untuk mendesain email khusus .

Kerentanan baru (CVE-2022-0218, skor CVSS 8.3) ditemukan oleh peneliti Wordfence Chloe Chamberland, dan disebabkan oleh konfigurasi yang salah pada rute REST-API yang digunakan untuk memperbarui template dan mengubah pengaturan, Chamberland menjelaskan dalam pengungkapan . Sederhananya, tidak ada otentikasi yang diperlukan untuk mengakses titik akhir REST-API.

“Oleh karena itu, setiap pengguna memiliki akses untuk menjalankan titik akhir REST-API untuk menyimpan pengaturan tema email atau mengambil pengaturan tema email,” tulis Chamberland. “[Mereka] dapat menyuntikkan JavaScript berbahaya ke dalam template email yang akan dijalankan kapan pun administrator situs mengakses editor email HTML.”

 

Itu berarti pelaku ancaman dapat menambahkan pengguna baru dengan kredensial administratif, menyuntikkan pintu belakang, menerapkan pengalihan situs, dan menggunakan situs yang sah template untuk mengirim email phishing, di antara banyak hal lainnya — bahkan pengambilalihan situs.

“Dikombinasikan dengan fakta bahwa kerentanan dapat dieksploitasi oleh penyerang tanpa hak istimewa di situs yang rentan, ini berarti ada kemungkinan besar penyerang yang tidak diautentikasi dapat memperolehnya akses pengguna administratif di situs yang menjalankan versi plugin yang rentan ketika berhasil dieksploitasi,” kata Chamberland.

Plugin Kompatibel dengan WooCommerce, Ninja Forms & Buddy Press

Plugin dipasang di 20.000 situs dan kompatibel dengan plugin lain yang dijalankan oleh situs WordPress dengan banyak pengikut seperti platform eCommerce WooCommerce, pembuat formulir online Ninja Forms dan plugin pembangun komunitas BuddyPress, Chamberland melaporkan.

“Kami menyarankan agar pemilik situs WordPress segera memverifikasi bahwa situs mereka telah diperbarui ke versi patch terbaru yang tersedia, yaitu versi 3.1 pada saat publikasi ini,” tambah Chamberland.

Pengungkapan terbaru ini datang hanya seminggu setelah Keamanan Berbasis Risiko merilis temuan mereka bahwa jumlah kerentanan plugin WordPress meledak tiga digit pada tahun 2021.

Pada minggu yang sama, tiga plugin WordPress dilaporkan dengan bug yang sama — memperlihatkan 84.000 situs yang menjalankan add-on eCommerce ke situs lengkap takeovers.

WordPress administrator situs disarankan oleh Chamberland untuk memastikan mereka menjalankan versi terbaru, Perancang Template Email WordPress — WP HTML Mail versi 3.1.

“Jika Anda mengenal teman atau kolega yang menggunakan plugin ini di situs mereka, kami sangat menyarankan untuk meneruskan nasihat ini kepada mereka untuk membantu menjaga situs mereka tetap terlindungi karena ini adalah kerentanan yang serius yang dapat menyebabkan pengambilalihan situs secara menyeluruh,” Chamberland memperingatkan.
Tulis komentar
Bagikan artikel ini:

  • Kerentananliu
      iKeamanan Web