Batch Lain Pembaruan Keamanan Kernel Linux Penting Tiba untuk Pengguna Ubuntu, Patch Sekarang


Canonical diterbitkan beberapa menit yang lalu satu set pembaruan keamanan kernel Linux penting untuk semua rilis Ubuntu yang didukung untuk mengatasi beberapa kerentanan keamanan.

Pembaruan keamanan kernel Linux baru datang satu setengah bulan setelah pembaruan sebelumnya dan tersedia untuk Ubuntu 21.04 (Hirsute Hippo), Ubuntu 20.04 LTS (Focal Fossa), dan seri sistem operasi Ubuntu 18.04 LTS (Bionic Beaver). Ini termasuk CVE-2021-3656 dan CVE-2021-3653, keduanya kelemahan yang memungkinkan penyerang di mesin virtual tamu untuk membaca atau menulis ke bagian dari memori fisik host, serta CVE-2021-22543, penggunaan-setelah- kerentanan gratis yang memungkinkan penyerang yang dapat memulai dan mengontrol mesin virtual untuk mengekspos informasi sensitif atau mengeksekusi kode arbitrer. Masalah ini ditemukan dan dilaporkan oleh Maxim Levitsky dan Paolo Bonzini.

Hanya untuk sistem Ubuntu 21.04 dan Ubuntu 20.04 LTS yang menjalankan kernel Linux 5.11, pembaruan keamanan baru memperbaiki cacat (CVE-2021-38198) yang ditemukan dalam implementasi hypervisor KVM kernel Linux yang dapat izinkan penyerang lokal menyebabkan penolakan layanan.

Hanya untuk sistem Ubuntu 20.04 LTS dan Ubuntu 18.04 LTS yang menjalankan kernel Linux 5.4, patch pembaruan keamanan kernel Ubuntu baru CVE-2020-36311, kelemahan lain yang ditemukan dalam implementasi hypervisor KVM untuk prosesor AMD yang memungkinkan penyerang lokal menyebabkan penolakan layanan (soft lockup).

Juga ditambal dalam pembaruan kernel Linux baru untuk sistem Ubuntu ini adalah CVE-2021-3612, kerentanan keamanan yang ditemukan oleh Murray McAllister di antarmuka perangkat joystick kernel Linux, yang dapat memungkinkan penyerang lokal merusak sistem yang rentan dengan menyebabkan serangan penolakan layanan atau mengeksekusi kode arbitrer pada sistem dengan j terdaftar perangkat oystick. Cacat ini memengaruhi semua rilis dan kernel Ubuntu yang didukung.

Hanya untuk sistem Ubuntu 21.04 dan Ubuntu 20.04 LTS yang menjalankan kernel Linux 5.11, pembaruan keamanan baru menambal beberapa kerentanan yang lebih penting, termasuk CVE-2020-26541, cacat yang dapat memungkinkan penyerang untuk melewati Pembatasan Boot Aman UEFI, CVE-2021-38206, dereferensi penunjuk nol yang ditemukan oleh Ben Greear di subsistem mac80211 kernel Linux yang dapat memungkinkan penyerang terdekat secara fisik menyebabkan penolakan layanan (kerusakan sistem), dan CVE-2021-38207, a cacat ditemukan di driver perangkat Xilinx LL TEMAC yang memungkinkan penyerang jarak jauh menyebabkan penolakan layanan (kerusakan sistem).

Sama berlaku untuk CVE-2021-34693, cacat yang ditemukan oleh Norbert Slusarek dalam protokol CAN broadcast manger (bcm) implementasi yang memungkinkan penyerang lokal untuk mengekspos informasi sensitif (memori kernel), dan CVE-2021-38200, masalah dereferensi penunjuk nol yang ditemukan di subsistem kinerja kernel Linux untuk PowerPC ar chitecture, yang memungkinkan penyerang menyebabkan penolakan layanan (system crash).

Canonical mendesak semua pengguna Ubuntu untuk memperbarui instalasi mereka sesegera mungkin ke versi kernel baru (linux-image-generic 5.11.0.34.36 untuk Ubuntu 21.04 dan Ubuntu 20.04 LTS, dan linux-image-generic 5.4.0.84.88 untuk Ubuntu 20.04 LTS dan Ubuntu 18.04 LTS). Harap dicatat bahwa Anda harus me-reboot sistem Anda setelah menginstal versi kernel baru untuk sepenuhnya ditambal terhadap kerentanan keamanan ini.

Sumber: Google, 9to5linux.com